Archive for the ‘Uncategorized’ Category

Ubuntu audio with Jack continued

Saturday, November 18th, 2017

Allright, allright, allright, allright, allright, allright. I got the original setup working again (just Timemachine is not working at the moment).

What was wrong?

  • No soundfont installed in Qsynth, so no sound!
  • Mixer not installed via synaptic
  • Timemachine not installed via synaptic
  • Patchbay config file missing
  • Mixer config file missing

Here is the screenshot again

And here is the script

#!/bin/bash

#clientNumOxygen=$(aconnect -i | grep client | grep -i Oxygen | cut -d” ” -f2 | tr -d “:”)

# Start Jack audio server
# Patchbay settings will make sure everything gets connected as is in the config file
# Config file to use is /home/spruit/muziekmaken/patchbaywithQsynthandMixer.xml
/usr/bin/qjackctl -s &
sleep 8

# Start Qsynth.
# You will need to have a sound font selected for the sound engine you use otherwise no sound.
# Select it via setup.
/usr/bin/qsynth -g 6 &
sleep 8

# Start Jack Mixer and load settings
# Can be installed via synaptic
# Points to /usr/share/jack-mixer/jack_mixer.py
/usr/bin/jack_mixer -c /home/spruit/muziekmaken/jack_mixer_settings &
sleep 8

# Start a2jmidid to route keyboard midi to jack_mixer. ALSA to Jack.
/usr/bin/a2jmidid -e &
sleep 8

# Start TimeMachine to record brainwaves
/usr/bin/timemachine &

# Start Patchage to route audio between components
# Basically does the same as Patchbay
/usr/bin/patchage &

# Connect the keyboard. Not needed, can do this with PatchBay
# aconnect $clientNumOxygen:0 130:0 &
# Connect a2jmidid. Not needed, can do this with PatchBay
# jack_connect a2j:”Oxygen 61 [$clientNumOxygen] (capture): Oxygen 61 MIDI 1″ jack_mixer:”midi in”

# Disconnect the default ports where we have put the mixer in between
jack_disconnect “PulseAudio JACK Sink”:front-left system:playback_1
jack_disconnect “PulseAudio JACK Sink”:front-right system:playback_2
jack_disconnect qsynth:l_00 system:playback_1
jack_disconnect qsynth:r_00 system:playback_2

Ubuntu audio with Jack continued

Saturday, November 18th, 2017

Dammit, I had to set up all the audio again in my new version of Ubuntu. The midi keyboard once again produces sound over my laptop. Still need to find out how I can get all the fancy sounds from it.

Below is the Patchbay and Patchage setup.

Here is the start up script:

#!/bin/bash

#clientNumOxygen=$(aconnect -i | grep client | grep -i Oxygen | cut -d” ” -f2 | tr -d “:”)

# Start Jack audio server
# Patchbay settings will make sure everything gets connected as is in the config file
# Config file is /home/spruit/muziekmaken/patchbaywithsynthv1.xml
/usr/bin/qjackctl -s &
sleep 8

# Start Qsynth, this does not seem to work anymore
# /usr/bin/qsynth -g 6 &
# Start synthv1 or yoshimi
/usr/bin/synthv1_jack &
# /usr/bin/yoshimi &
sleep 8

# Start Jack Mixer and load settings
# Points to /usr/share/jack-mixer/jack_mixer.py
# Nog knoppen op keyboard definieren om volume te regelen
# This program is no longer available on the current Ubuntu version
# /usr/bin/jack_mixer -c /home/spruit/muziekmaken/jack_mixer_settings &
# sleep 8

# Start a2jmidid to route keyboard midi to jack_mixer. ALSA to Jack.
/usr/bin/a2jmidid -e &
sleep 8

# Start TimeMachine to record brainwaves
# /usr/bin/timemachine &

# Start Patchage to route audio between components
# Basically does the same as Patchbay
/usr/bin/patchage &

# Connect the keyboard. Not needed, can do this with Patchbay
# aconnect $clientNumOxygen:0 130:0 &
# Connect a2jmidid. Not needed, can do this with Patchbay
# jack_connect a2j:”Oxygen 61 [$clientNumOxygen] (capture): Oxygen 61 MIDI 1″ jack_mixer:”midi in”
# Disconnect the default ports where we have put the mixer in between
# jack_disconnect “PulseAudio JACK Sink”:front-left system:playback_1
# jack_disconnect “PulseAudio JACK Sink”:front-right system:playback_2
# jack_disconnect qsynth:l_00 system:playback_1
# jack_disconnect qsynth:r_00 system:playback_2

Fun at the local park

Saturday, April 30th, 2016

treflip

Voetbal

Thursday, September 24th, 2015

Ik ben leider van de OSC F9. Wat is dat geweldig! Elke zaterdag trekken we ten strijde.

SONY DSC

Copy files on Linux with exclude

Saturday, May 16th, 2015

This is what I use to make a backup copy of all my images to a temporary folder in Linux. It excludes a number of file extensions, like the ones for movies. It is executed from the folder that contains the files you want to copy.

sudo tar cvf - * --exclude *.MTS --exclude *.mpg --exclude 
*.MPG --exclude *.mp4 --exclude *.modd --exclude *.db 
--exclude *.avi --exclude *.AVI --exclude *.THM --exclude 
*.idx --exclude *.info --exclude *.mov --exclude *.MOV 
--exclude *.zip --exclude *.dat --exclude *.db  --exclude 
adirectory/* | ( cd /media/spruit/ausbstick; tar xfp -)

Trickipedia

Saturday, February 28th, 2015

From now on my log of skateboarding tricks has a dedicated page.

Voortgang 4

Saturday, January 17th, 2015

Flatground:

Pressure flip

Switch kickflip

Switch varial heel

Manual

Nose manual

Nollie flip

Obstacle:

Frontside boardslide

Flatground, alleen op tapijt:

Dolphin flip

Switch backside bigspin

Switch front foot impossible

Voortgang 3

Saturday, November 8th, 2014

Flatground, alleen op tapijt:

Double kickflip

Hardflip

Switch hardflip

Switch tre flip

360 backside shovit

Switch 360 backside shovit

Flatground:

Backside bigspin

Obstacle:

Frontside tail slide

Jack issue after upgrading to Ubuntu 14.04

Saturday, September 20th, 2014

After upgrading Ubuntu to 14.04 I had two problems.

– No sound from Spotify via webbrowser anymore.

Solved by: Installing pulseaudio-module-jack (4.0-0ubuntu11). This caused my PulseAudio JACK Sink to be available again. In PulseAudio Volume Control I then had to set the ALSA plug-in (under tab Afspelen/Play) to Jack sink.

– No connection anymore between my midi keyboard and the Jack Mixer. I could not control the volume in Jack Mixer via my keyboard anymore. The connection was visible in the JACK Audio Connection Kit via Patchbay (loaded via my patchbay configuration file patchbaydefault.xml), but did not get propagated to my connections in the JACK Audio Connection Kit. This was caused by a change in the name of the plug for my midi keyboard. Probably due to some previous re-installing.

Old value in patchbaydefault.xml:

<socket exclusive=”off” client=”a2j” type=”jack-midi” name=”a2j_Oxygen_61″><plug>Oxygen 61 \[20\] \(capture\): Oxygen 61 MIDI 1</plug></socket>

New value that worked:

<socket exclusive=”off” client=”a2j” type=”jack-midi” name=”a2j_Oxygen_61″><plug>Oxygen 61 \[24\] \(capture\): Oxygen 61 MIDI 1</plug></socket>

Solved by: Deleting the plugs via Patchbay and re-creating the connection. I probably also could have changed the xml file directly.

Voortgang 2

Saturday, August 30th, 2014

Flatground:

Tre-flip

Switch backside shovit revert

Fakie bigspin

Nollie

 

Flatground (alleen op tapijt):

Varial heel

Varial flip

Switch varial flip

 

Obstacle:

50/50 (quarterpipe)

Nose slide